Utiliser des applications Java 1.5 (Java 5) sur OSX Snow Leopard

Certaines applications Java n'ont pas encore été migrées vers l'environnement Java 1.6 (ou Java 6).

Or Snow Leopard n'est livré qu'avec Java 1.6...

Voyons ici comment réactiver Java 1.5 (et éventuellement Java 1.4 sur le même principe) pour faire fonctionner ces belles applications.... En attendant qu'elles soient mises à jour ;)

Java

Pré requis :

Mode opératoire :

  • Utilisez le Shareware Pacifist afin d'ouvrir l'archive java ainsi téléchargée
  • Ouvrez le finder et aller avec le raccourci "Shift" + "Cmd" + G dans le dossier /System/Library/Frameworks/JavaVM.framework/Versions/
  • Supprimer les 2 liens symboliques "1.5" et "1.5.0". Cette étape est cruciale, ca si vous ne la faites pas, vous allez endommager Java 1.6. Le mot de passe administrateur vous sera demandé pour cette opération.
  • Dans Pacifist, aller dans Contents » System » Library » Frameworks » JavaVM.framework » Versions

Sélection de la version de Java

  • Sélectionner les 2 dossiers "1.5" et "1.5.0", puis control Click (ou click droit) sur la sélection, et choisir "Install to default location"
  • Le dossier 1.5.0 et le lien symbolique de 1.5 vers 1.5.0 seront recréés lors de cette opération.
  • Répéter les opération si nécessaire pour Java 1.4
  • Pour forcer l'utilisation d'un version particulière, utlilisez l'utilitaire "Préférences JAVA" dans le dossier "Utilitaires" afin de désélectionner les version non souhaités.

Dans mon cas, cela a admirablement bien marché pour faire fonctionner l'éditeur de sons livré avec le POD 2.0 de Line 6...